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IMPORTING A DIF FILE INTO ALLOCATION
AND APPORTIONMENT
Templates are provided for use in importing and exporting from A&AData Entry for the 2021 year. A&A factor
detail may be tabulated on the spreadsheet, saved as a DIF file, and transferred to A&AData Entry. Also, detail
in Data Entry may be exported to a DIF spreadsheet file.

Be sure to save the *.xls file as a DIF file before you import, as follows: In the spreadsheet application, select
File > Save As > DIF (Data Interchange Format).

The KAT template goes with the spreadsheet, so you cannot insert rows or columns to the spreadsheet.

DETACHING AND SAVING THE TEMPLATES
1. Right-click the zip file, and select Save Target As.

2. Detach into a designated folder on your hard drive.

3. Expand the zip file into its two components.

For 1065: 1065_AA2021.DIF and 1065_AA2021.KAT

For 1120: 1120_AA2021.DIF and 1120_AA2021.KAT.

IMPORTING THE DATA INTO THE TAX APPLICATION
Use the Import DIF dialog box to import the data in the source file into the tax application.

Please confirm that the .DIF/.KAT file selected is the correct return type for your import.

1. Standardize your spreadsheet format (layout) so that it can be used for other clients.

2. Save a version of the spreadsheet as a DIF (Data Interchange Format) file.

3. On the top menu, click Tools > Import. The Import DIF dialog box appears.

4. In the DIF Import File section, clickBrowse for File to locate the source DIF file.
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3 Importing a DIF File into Allocation and Apportionment

Importing the Data into the Tax Application

5. In the DIF Template File section, clickBrowse for File to locate the .KAT file. AllDIF template files must
have a .KAT extension.

6. Click Import.
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1065 ALLOCATION AND APPORTIONMENT
ORGANIZER/OVERRIDE DIF/KAT IMPORT:
INSTRUCTIONS
Templates are provided for use in importing and exporting from A&AData Entry for the 2021 year. A&A factor
detail may be tabulated on the spreadsheet, saved as a DIF file, and transferred to A&AData Entry. Also, detail
in Data Entry may be exported to a DIF spreadsheet file.

Be sure to save the *.xls file as a DIF file before you import, as follows: In the spreadsheet application, select
File > Save As > DIF (Data Interchange Format).

The KAT template goes with the spreadsheet, so you cannot insert rows or columns to the spreadsheet.

DETACHING AND SAVING THE TEMPLATES
1. Right-click the zip file, and select Save Target As.

2. Extract files into a designated folder on your hard drive.

3. Expand the zip file into its components: 1065_AAOO2015.DIF and 1065_AAOO2015.KAT.

IMPORTING THE DATA INTO THE TAX APPLICATION
Use the Import DIF dialog box to import the data in the source file into the tax application.

Please confirm that the .DIF/.KAT file selected is the correct return type for your import.

1. Standardize your spreadsheet format (layout) so that it can be used for other clients.

2. Save a version of the spreadsheet as a DIF (Data Interchange Format) file.

3. On the top menu, click Tools > Import. The Import DIF dialog box appears.

4. In the DIF Import File section, clickBrowse for File to locate the source DIF file.

5. In the DIF Template File section, clickBrowse for File to locate the .KAT file. AllDIF template files must
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5 1065 Allocation and Apportionment Organizer/Override DIF/KAT Import: Instructions

Importing the Data into the Tax Application

have a .KAT extension.

6. Click Import.
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1065 OHIO CITIES ALLOCATION AND
APPORTIONMENT DIF/KAT IMPORT:
INSTRUCTIONS
Use the files contained in the ZIP file, 2021_1065_Ohio_Cities.DIF and 2021_1065_Ohio_Cities.KAT, to
import Ohio City Allocation and Apportionment information into the Allocation & Apportionment > A&A
Data Entry > Ohio Cities Data Entry screen. Once entered, this information will flow to each Ohio city
included as part of the import process.

USING THE DIF TEMPLATE FOR OHIO CITIES
ALLOCATION AND APPORTIONMENT
Use the 2021_1065_Ohio_Cities.DIF template file to create a DIF source file in Excel (or any other
spreadsheet software). Make a copy of the template DIF file, and save the file with a name identifiable with the
related tax return. Once data entry into this source DIF file is complete, you must use DIF Import to exchange
data.

1. Ohio city codes are provided in the 2021_Ohio_City_Codes.XLS file included in the toolkit. Codes can
be copied from this spreadsheet into the source DIF file to minimize manual code entry. Each code is
unique to one Ohio city and its associated taxing authority (CCA, RITA, Cincinnati, Columbus, or Generic).

2. Ohio city names are calculated in the software based on the city code. City names should not be
overridden in the source DIF import file to a different city name from the name associated with its city code.
City name overrides may change the city name displayed in Organizer but will not change the city return
produced by the software.

3. Ohio city taxing authority codes included as part of the city code listings in the 2021_Ohio_City_
Codes.XLS file should not be copied into the source DIF file. The taxing authority code is computed
automatically by the software but can be overridden if the taxing authority changes.

4. Ohio city codes may be imported without A&A data. A&A data should be manually entered or copied into
the source DIF file based on the column order found in the DIF file. The 2021_1065_Ohio_Cities.KAT
template file has been built to match the column order of the template DIF file. Do not insert or delete rows
or columns that change the column header section of the DIF file.

5. Once data entry is complete, save the file as a DIF (Data Interchange Format) file. If using Excel, select
File > Save As, and selectDIF (Data Exchange Format) (*.DIF) from the Save As Type drop-down list.
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7 1065 Ohio Cities Allocation and Apportionment DIF/KAT Import: Instructions

Importing the Data into the Tax Application

IMPORTING THE DATA INTO THE TAX APPLICATION
Use the Import DIF dialog box to import the data in the source file into the tax application.

Please confirm that the .DIF/.KAT file selected is the correct return type for your import.

1. Standardize your spreadsheet format (layout) so that it can be used for other clients.

2. Save a version of the spreadsheet as a DIF (Data Interchange Format) file.

3. On the top menu, click Tools > Import. The Import DIF dialog box appears.

4. In the DIF Import File section, clickBrowse for File to locate the source DIF file.

5. In the DIF Template File section, clickBrowse for File to locate the .KAT file. AllDIF template files must
have a .KAT extension.

6. Click Import.
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1120 FORM 851 DIF/KAT IMPORT:
INSTRUCTIONS
Use these files to import information into Form 851 in the 1120 product when consolidating.

STEPS TO IMPORT FILES FOR FORM 851, PARTS II, III,
AND IV
Use the files contained in the zip file (851_2.KAT for Part II of Form 851, 851_3.KAT for Part III of Form 851,
851_4.KAT for Part IV of Form 851, and 851.XLS for Form 851) importing. To extract the files:

1. Double-click the zip file.

2. Select the files.

3. Click the Extract icon.

4. Navigate to the location where you want to save the files. The location appears in the Extract to field.

5. Click the Extract button.

6. Be sure to save the XLS file as a DIF file before you import.

7. In the spreadsheet application (Excel), open the File menu.

8. Select Save As.

9. SelectDIF (Data Interchange Format) from the Save as type drop-down list.

10. The KAT template goes with the spreadsheet, so you cannot insert rows or columns into the spreadsheet.

IMPORTING THE DATA INTO THE TAX APPLICATION
Use the Import DIF dialog box to import the data in the source file into the tax application.

Please confirm that the .DIF/.KAT file selected is the correct return type for your import.
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9 1120 Form 851 DIF/KAT Import: Instructions

Importing the Data into the Tax Application

1. Standardize your spreadsheet format (layout) so that it can be used for other clients.

2. Save a version of the spreadsheet as a DIF (Data Interchange Format) file.

3. On the top menu, click Tools > Import. The Import DIF dialog box appears.

4. In the DIF Import File section, clickBrowse for File to locate the source DIF file.

5. In the DIF Template File section, clickBrowse for File to locate the .KAT file. AllDIF template files must
have a .KAT extension.

6. Click Import.
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1120 ESTIMATES AND EXTENSIONS
DIF/KAT IMPORT: INSTRUCTIONS
Use the files contained in the ZIP file, Estext17.DIF and Estext17.KAT, to import State Estimate and
Extension information into the Common State > Extensions and Estimates screen. Once entered, this
information will flow into each state.

USING THE DIF TEMPLATE
Once you have created a data source file in Excel (or any other spreadsheet software), add any formulas or
formatting you prefer. Then you must use DIF Import to exchange data.

1. Standardize your spreadsheet format (layout) so that it can be used for other returns.

2. Before saving the file as a DIF file, make certain any date information is formatted in theMM/DD/YYYY
format (such as 03/22/2021). Otherwise, when you import the information, you will receive invalid date
messages.

3. Save a version of the spreadsheet as a DIF (Data Interchange Format) file. If using Excel, select File >
Save As, and selectDIF (Data Exchange Format) (*.DIF) from the Save As Type drop-down list.

IMPORTING THE DATA INTO THE TAX APPLICATION
Use the Import DIF dialog box to import the data in the source file into the tax application.

Please confirm that the .DIF/.KAT file selected is the correct return type for your import.

1. Standardize your spreadsheet format (layout) so that it can be used for other clients.

2. Save a version of the spreadsheet as a DIF (Data Interchange Format) file.

3. On the top menu, click Tools > Import. The Import DIF dialog box appears.

4. In the DIF Import File section, clickBrowse for File to locate the source DIF file.

5. In the DIF Template File section, clickBrowse for File to locate the .KAT file. AllDIF template files must
have a .KAT extension.

6. Click Import.
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1120 OHIO CITIES ALLOCATION AND
APPORTIONMENT DIF/KAT IMPORT:
INSTRUCTIONS
Use the files contained in the ZIP file, 2021_1120_Ohio_Cities.DIF and 2021_1120_Ohio_Cities.KAT, to
import Ohio City Allocation and Apportionment information into the Allocation & Apportionment > A&A
Data Entry > Ohio Cities Data Entry screen. Once entered, this information will flow to each Ohio city
included as part of the import process.

USING THE DIF TEMPLATE FOR OHIO CITIES
ALLOCATION AND APPORTIONMENT
Use the 2021_1120_Ohio_Cities.DIF template file to create a DIF source file in Excel (or any other
spreadsheet software). Make a copy of the template DIF file, and save the file with a name identifiable with the
related tax return. Once data entry into this source DIF file is complete, you must use DIF Import to exchange
data.

1. Ohio city codes are provided in the 2021_Ohio_City_Codes.XLS file included in the toolkit. Codes can
be copied from this spreadsheet into the source DIF file to minimize manual code entry. Each code is
unique to one Ohio city and its associated taxing authority (CCA, RITA, Cincinnati, Columbus, or Generic).

2. Ohio city names are calculated in the software based on the city code. City names should not be
overridden in the source DIF import file to a different city name from the name associated with its city code.
City name overrides may change the city name displayed in Organizer but will not change the city return
produced by the software.

3. Ohio city taxing authority codes included as part of the city code listings in the 2021_Ohio_City_
Codes.XLS file should not be copied into the source DIF file. The taxing authority code is computed
automatically by the software but can be overridden if the taxing authority changes.

4. Ohio city codes may be imported without A&A data. A&A data should be manually entered or copied into
the source DIF file based on the column order found in the DIF file. The 2021_1120_Ohio_Cities.KAT
template file has been built to match the column order of the template DIF file. Do not insert or delete rows
or columns that change the column header section of the DIF file.

5. Once data entry is complete, save the file as a DIF (Data Interchange Format) file. If using Excel, select
File > Save As, and selectDIF (Data Exchange Format) (*.DIF) from the Save As Type drop-down list.
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12 1120 Ohio Cities Allocation and Apportionment DIF/KAT Import: Instructions

Importing the Data into the Tax Application

IMPORTING THE DATA INTO THE TAX APPLICATION
Use the Import DIF dialog box to import the data in the source file into the tax application.

Please confirm that the .DIF/.KAT file selected is the correct return type for your import.

1. Standardize your spreadsheet format (layout) so that it can be used for other clients.

2. Save a version of the spreadsheet as a DIF (Data Interchange Format) file.

3. On the top menu, click Tools > Import. The Import DIF dialog box appears.

4. In the DIF Import File section, clickBrowse for File to locate the source DIF file.

5. In the DIF Template File section, clickBrowse for File to locate the .KAT file. AllDIF template files must
have a .KAT extension.

6. Click Import.
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SCHEDULE M-3 DIF/KAT IMPORT:
INSTRUCTIONS

MIXED GROUP TEMPLATES
M-3 import templates are provided for the 2021 Schedule M-3 Parts I, II, and III of the Mixed Group return.
Schedule M-3 detail may be tabulated on a spreadsheet, saved as a DIF file, and transferred into the return (for
Forms 1120, 1120L, and 1120PC).

Each DIF file has to be used with its respective KAT file. The KAT file goes with the spreadsheet, so you
cannot insert nor delete rows or columns in the DIF file.

TopCon M-3 Part I format (Mixed Group)
1. Topcon (Top consolidation) only.

2. Columns A through BB are Part I single and group field items.

3. Columns BD through BE are Total Assets and Total Liabilities.

1120L M-3 Parts II & III format (Member Company)
1. Column A is Part II description.

2. Columns B through D are Part II single field items.

3. Columns E through CK are Part II group field items.

4. Column CL is Part III description.

5. Columns CM through CO are Part III single field items.

6. Columns CP through DK are Part III group field items.
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14 Schedule M-3 DIF/KAT Import: Instructions

Detaching and Saving the Templates

1120PCM-3 Parts II & III format (Member Company)
1. Column A is Part II description.

2. Columns B through D are Part II single field items.

3. Columns E through CQ are Part II group field items.

4. Column CR is Part III description.

5. Columns CS through CU are Part III single field items.

6. Columns CV through DWare Part III group field items.

DETACHING AND SAVING THE TEMPLATES
1. Right-click the zip file, and select Save Target As.

2. Detach into a designated folder on your hard drive.

3. Expand the zip files:

l M3TOPCONPT1.DIF,M3TOPCONPT1.KAT.

l M3Life.DIF,M3Life.KAT

l M3PC.DIF,M3PC.KAT

IMPORTING THE DATA INTO THE TAX APPLICATION
Use the Import DIF dialog box to import the data in the source file into the tax application.

Please confirm that the .DIF/.KAT file selected is the correct return type for your import.

1. Standardize your spreadsheet format (layout) so that it can be used for other clients.

2. Save a version of the spreadsheet as a DIF (Data Interchange Format) file.

3. On the top menu, click Tools > Import. The Import DIF dialog box appears.

4. In the DIF Import File section, clickBrowse for File to locate the source DIF file.
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Schedule M-3 DIF/KAT Import: Instructions 15

Importing the Data into the Tax Application

5. In the DIF Template File section, clickBrowse for File to locate the .KAT file. AllDIF template files must
have a .KAT extension.

6. Click Import.
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