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CHAPTER 1: FORMSOURCE

WHAT IS FORMSOURCE?
This application is a comprehensive tool you can use to search your firm’s tax returns for specific information.

Using this application, you can easily find clients that meet criteria that you define. You create query statements
that define the data and conditions that you need, and the application searches the tax return data and then
displays a listing of all matching returns. For example, suppose you need to know the names of all of your 1120
clients with tax-deductible contributions greater than $1,000 in a given year. Instead of searching through client
files, you can create a query and quickly gather the information.

KEY FEATURES
l Completely customizable: you set the criteria used for the query as well as the data included in the result.

l All tax return, workpaper, and Organizer fields in the 1040, 1041, 1065, 1120, and 990 tax applications
can be searched and included in the results.

l You can save queries for later use.

l You can view, save, and print the query results in Microsoft Excel or tabular text format.

l You can search multiple accounts at one time; there is no need for firms with multiple offices to query each
site and then merge and manipulate the data.

l Your firm’s complete 1040, 1041, 1065, 1120 and 990 tax return data is automatically loaded in separate
databases a few hours after a return is closed. The exact load time depends on the volume of returns
processing.

BEFORE YOU BEGIN
Before creating a query, first carefully consider exactly what information you are seeking and get detailed
requirements. Starting with a clear, concise query definition will yield accurate, useful query results.

You may need the knowledge and expertise of a tax preparer familiar with our software to identify the tax
application fields that are needed for the query criteria. There can be several different sources of data and
required computations that affect tax return data.
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2 Chapter 1: FormSource
Before You Begin

Amajor consideration for any query is the type and source of the data you need to query. In this application, you
can search for information on the tax return, workpaper, or Organizer level. Generally, you should query a tax
form field whenever possible. By doing so, you retrieve fully computed data along with any overrides. However,
there are situations when you need to query an Organizer field. These situations include:

l Data entered on Organizer screens that is used in computations, but does not appear on a tax form.

l Computation and processing type options like the federal and state estimate options.

l Taxpayer identification data, such as name, address, and ID number. Querying these Organizer fields is
necessary because different tax returns can be prepared from within the same application, such as 1120
and 1120S returns prepared from within the 1120 application. Typically, these tax returns share Organizer
fields for common information. Using these common fields limits the size and complexity of your actual
query. Additionally, you can view all of the information for each type of identifying data in one column
instead of in a separate column for each tax return type.

Another factor to consider is the complexity and number of fields included in a single query. This application
limits the number of characters that can be stored for each query. The Define Query and Define Report tabs
store 3600 characters each. Since the names for each form and field vary in length, we cannot provide an
absolute number of fields that you can include on each tab. When you attempt to save a query that exceeds the
maximum limit, you receive the following message:

Report String has exceeded maximum length. Remove some selected fields.

The message appears until the number of fields that you selected is below the 3600 character limit. Therefore,
in some situations you must reevaluate your query requirements and the results you need to generate.
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CHAPTER 2: CREATING A QUERY
The following steps are an overview of how to create a query. The steps are further explained in this section.

1. Accessing the Application (page 3)

2. Selecting the Tax Year and Tax Application Type (page 4)

3. Defining the Query Criteria (page 5)

4. Defining the Query Report (page 10)

5. Selecting the Accounts (page 11)

6. Running the Query (page 11)

7. Analyzing and Validating the Results (page 12)

8. Printing the Results (page 13)

ADDITIONAL INFORMATION
Examples (page 14)

Creating Queries (page 23)

ACCESSING THE APPLICATION
On the RSBrowser screen, selectReturns Processing > Import/Export > FormSource. The following
screen appears.
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4 Chapter 2: Creating a Query

Selecting the Tax Year and Tax Application Type

Figure 2:1

Using or accessing this application is a user right granted by your RSAdministrator.

SELECTING THE TAX YEAR AND TAX APPLICATION TYPE
1. On the Saved Queries tab, select the tax year and the tax application type (1040, 1041, 1065, 1120, or

990). The user name is automatically filled in with the name you used to log in to the application. The list of
your saved queries will appear.

2. Clear the user name field to see all saved queries for your firm. Click the Refresh List button to view the
list.

You can also enter another user name to narrow the list of existing queries created and saved by another
user.

If this is your first time using FormSource or you have not created or stored a query, a
message will display saying there are no stored queries. ClickOK to continue.
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Chapter 2: Creating a Query 5

Defining the Query Criteria

3. To use a predefined query from Thomson Reuters, check the box for FormSource Library. You must
select the tax year and tax return type first. A list of predefined queries will appear in the box below. For a
list of the predefined queries, see FormSource Libraries (page 27).

Figure 2:2

DEFINING THE QUERY CRITERIA
1. To create a newQuery, select the Define Query tab (or on the Saved Queries tab, click the Create

Query button) to enter the criteria for your query.
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6 Chapter 2: Creating a Query

Defining the Query Criteria

2. To review or change a saved query, highlight the query name on the Saved Queries tab and select the
Edit Query button. The Define Query screen appears.

Figure 2:3

3. First, select the Form Type, Form, and Field Name, which you want to include in the query. The Form
Type includes all the areas you can query from in the tax application. The Form and Field drop-down lists
display the applicable items available based on your Form Type selection and the Return Type selection
you made on the Saved Queries tab.

See Creating Queries (page 23) for help in using the drop-down lists (Form Type, Form, and Field) to
define the query criteria.
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Chapter 2: Creating a Query 7

Defining the Query Criteria

4. For prior year and current year queries, right-click any field in the tax application to find this information.

a. Open a prior year or current year tax return and navigate to the field on the applicable Organizer, tax
form, or workpaper screen that you know has the data you want to include in your query.

b. Right-click the field to view the Form Type, Form Name, and Field Name.

The system is unable to query personally identifiable information. Examples
are Social Security numbers and employer identification numbers.

For example, to see the FormSource information for Form 1040, Page 1, line 15, right-click the field,
and selectData Dictionary on the right-click menu.

Figure 2:4

You will see the Form Type, Form Name, and Field Name for the selected field.

Figure 2:5
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8 Chapter 2: Creating a Query

Defining the Query Criteria

5. Click back to the FormSource window and make the selections in the Form Type, Form, and Field drop-
down lists on the Define Query tab.

In this example, select Federal Tax Form in the Form Type drop-down list, FORM 1040 on the Form list,
and TAXINCOME on the Field list.

Figure 2:6
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Chapter 2: Creating a Query 9

Defining the Query Criteria

6. Next, select a Condition to set the parameters of the field to be queried:

CONDITION DESCRIPTION

< less than

> greater than

<= less than or equal to

>= greater than or equal to

= equal to

< > not equal to

Use the Value field to enter the specific alphanumeric or numeric data to be queried.

To query for simple field existence, the condition would be not equal to (<>) and the value would be blank.
For example, to find all 1040 returns with any amount on Form 1040, line 1, the criterion is 1040| T|
FORM 1040| WAGES| <>|""|.

If you have a tax return that includes the data you would like to query, then open the return
and copy data and paste it into Define Query or Define Report tabs in FormSource.

You cannot generate a query using partial strings of words within a field. You can search only for exact
matches. No wild card values exist. For example, if you create a query in which you ask for all tax returns
where the taxpayers’ occupation is teacher, only returns that use the exact term teacher appear. Any
taxpayers with the occupation junior high school teacher would not be identified.

7. ClickAdd to insert the completed criterion into the query. It will then appear in the Selection Criteria box.

8. To delete a criterion, select the line to be deleted and clickDEL.

9. To add additional criteria, follow the steps above again and clickAnd orOr to determine if both criteria
must be met or if only one of the criterion must be met in order to show the return in the result set. Use
And if both criteria must be met. UseOr if only one criterion must be met.
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10 Chapter 2: Creating a Query

Defining the Query Report

10. To group criterion together within parentheses, select the criteria and then click ( or ). Using parentheses
eliminates the need to repeat criteria. For example, if you would like to find all 1040 returns that have AGI
greater than $100,000 and dividends greater than $1,000 or interest less than $1,000, create a query with
the following criteria:

1040|T|Form 1040|AGI|>|100000| AND

(

1040|T|Form 1040|Dividend|>|1000| OR

1040|T|Form 1040|Interest|<|1000|

)

Only one set of parentheses is allowed in each query.

11. To remove an And/Or criterion, select the criterion, and click the And/Or button.

To change the order of the criterion, highlight a line and click either the Up or Down button. Continue until
the fields are in the order that you want.

After you add a criterion, you can edit it by selecting the field you want to edit and then clicking the drop-
down list to select your new choice.

The field you select for a query criterion will also appear on the Define Report tab. If you
do not want a field to appear on the Define Report tab, clear the Include Field in Report
check box before you add the criterion. You can also delete a selected field on the Define
Report tab.

DEFINING THE QUERY REPORT
1. Select the information that will be displayed for the returns that match your query criteria on the Define

Report tab. The account and return numbers are automatically included in all query reports. The fields
that you include in your query criteria are also automatically included unless you cleared the Include
Field in Report check box on the Define Query screen before adding the criterion. You can also add
and delete fields on the Define Report screen.

2. Use the same steps to select the Form Type, Form and Field names that you used on the Define Query
tab.

GOSYSTEM TAX
FORMSOURCE GUIDE



Chapter 2: Creating a Query 11

Selecting the Accounts

SELECTING THE ACCOUNTS
1. From the Select Accounts tab, select the account(s) you want to include in the query. You must select at

least one account.

2. On the list of available accounts, an asterisk (*) indicates that the account’s FormSource database for the
tax year and type you selected is not complete. This occurs if Thomson Reuters has to perform
maintenance on the FormSource database. Your account(s) are updated automatically as quickly as
possible.

Check the Select Accounts tab periodically to verify that the data load has been completed. Your results
may not be accurate if you run a query on accounts before the data load is finished.

Figure 2:7

RUNNING THE QUERY
Use the following steps to run a query.

1. Select the Run Query tab. If you are running a saved query, the user name (if applicable) and the query
name appear automatically.
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12 Chapter 2: Creating a Query

Analyzing and Validating the Results

2. By default, the Retrieve Fields with No Data when applicable check box is checked. This means that
you can search for fields with a zero or nonexistent value (=0). It also means that less than queries
identify returns when the Criteria Field equals zero. You can click the hyperlink on the screen for a more
detailed explanation of this feature.

3. ClickRun Query. You can display the results in a tabular text format or delimited format.

Once the query begins to run, you cannot select other or Browser functions until the
query is complete.

Figure 2:8

To export your query results, select the Download CSV check box. This allows you to
view and open the data in a delimited form.

4. If the query results are voluminous, you can stop the download of the results by clicking Interrupt Query.
You may want to go back and modify your query to yield a smaller result set.

ANALYZING AND VALIDATING THE RESULTS
1. Verify that all the returns listed meet your query criteria and that you have not excluded any valid returns or

included invalid ones.
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Chapter 2: Creating a Query 13

Printing the Results

2. When analyzing the results, use a “reasonableness” test. Are the results valid for the type and number of
returns in your tax practice? For example, if your tax practice includes a large number of wealthy clients
and you run a query for 1040 returns with AGI over $100,000, but the results show only a few returns, then
you should examine your criteria and run the query again.

For complex queries, you should open a small sample of the returns found to verify that the data is from
the correct tax application source and meets the query requirements.

3. If you do not receive the expected results, then consider refining your query.

PRINTING THE RESULTS
1. Select File > Print from the display window.

2. To save the results:

l If you chose to display the results in Microsoft Excel, select File > Save As.

l If you chose to display the results in the tabular text format, select Edit > Select All, or select just the
results you want to save, then select Edit > Copy. You can paste the results into another document
or spreadsheet file.

You must close Microsoft Excel before running another query.

The Excel option only works for the 32-bit version of Excel.
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CHAPTER 3: EXAMPLES
The following illustrate some common uses of FormSource.

l Example - 1040 IRA Required Minimum Distribution Reminder Letters (page 14)

l Example - 1040 Clients Benefiting from Education Expense Planning (page 16)

l Example - 1120C Corporations with Estimated Tax Penalties (page 18)

l Example - 1065 Maryland Partnerships with Nonresident Partners (page 20)

EXAMPLE - 1040 IRA REQUIRED MINIMUM DISTRIBUTION
REMINDER LETTERS
A firm needs to contact clients who reach age 70-1/2 at any time during the year in order to inform them of the
IRA rules regarding required minimum distributions. The query results should include the taxpayers’ names.

Query Criteria
To identify the clients, query the 1040 tax returns for all taxpayers and/or spouses with a birth date between
July 1, 1951 and June 30, 1952. The taxpayer and spouse dates of birth are used on the 1040 tax return to
determine if the age 65 or older exemptions apply. These dates do not appear on the tax return, so you would
find this information on the federal Organizer screen.
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15 Chapter 3: Examples

Example - 1040 IRA Required Minimum Distribution Reminder Letters

Figure 3:1

Figure 3:2
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Chapter 3: Examples 16

Example - 1040 Clients Benefiting from Education Expense Planning

Report Fields Example

Figure 3:3

EXAMPLE - 1040 CLIENTS BENEFITING FROM
EDUCATION EXPENSE PLANNING
A firm wants to expand its tax planning practice by contacting clients that could receive a tax benefit from
starting educational savings accounts for qualified dependents.

Query Criteria
One way to accomplish this is to search for all 1040 clients with dependents who are age of 18 or under during
the year (born after 12/31/2004. The dependent date of birth is found on the federal Organizer:
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17 Chapter 3: Examples

Example - 1040 Clients Benefiting from Education Expense Planning

Figure 3:4
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Chapter 3: Examples 18

Example - 1120C Corporations with Estimated Tax Penalties

Reports Field Example

Figure 3:5

EXAMPLE - 1120C CORPORATIONS WITH ESTIMATED
TAX PENALTIES

Query Criteria
The firm prepares a variety of 1120 returns so a query criterion should be included to check for the C
Corporation return type. Additionally, this situation requires some tax knowledge because of the underpayment
penalty compute and print options that are available. The estimated tax penalty may be computed on Form
2200 but not carried to Form 1120, Page 1, line 34. Querying only the Form 1120 field will not generate
complete results. Both fields should be included in the query to ensure that all applicable returns are identified.
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19 Chapter 3: Examples

Example - 1120C Corporations with Estimated Tax Penalties

Figure 3:6
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Chapter 3: Examples 20

Example - 1065 Maryland Partnerships with Nonresident Partners

Result Selections Example

Figure 3:7

EXAMPLE - 1065 MARYLAND PARTNERSHIPS WITH
NONRESIDENT PARTNERS
A new state law requires partnerships with a nonresident partner to pay estimated tax on behalf of the
nonresident partner(s).

Query Criteria
The criteria should include a check for partnership returns that file a Maryland return and have any partners
that are not residents of Maryland.
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21 Chapter 3: Examples

Example - 1065 Maryland Partnerships with Nonresident Partners

Figure 3:8
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Chapter 3: Examples 22

Example - 1065 Maryland Partnerships with Nonresident Partners

Report Fields Example

Figure 3:9

GOSYSTEM TAX
FORMSOURCE GUIDE



CHAPTER 4: CREATING QUERIES
Different types of tax returns exist within several of the applications. At times, you may find that your query
identifies tax returns that you did not expect to be included in your results. Generally, this situation exists
because the application must compute (but not necessarily print) tax forms that may contain your selected tax
data in order to arrive at the correct result.

For example, some states do not recognize the SCorporation status and require the corporation to file a state
C Corporation return. This requires the 1120 tax application to compute Form 1120 even though the federal
return is an 1120S, so that appropriate data can flow to the state C Corporation tax return. Because Form 1120
is computed or considered “active,” data from this form loads into the database, whether you are processing an
actual C Corporation or S Corporation tax return.

In your query, you may want to include a return type criterion to limit the result set to the data you actually need.
The sections below detail the form type, form name, field name and conditions you should use to find the return
types.

QUERYING SELECTION-TYPE FIELDS IN THE
APPLICATION
Typically, the tax applications do not store the phrases that you see on a drop-down list, option button, or check
box. Instead, a corresponding alphanumeric character code is stored. You must search for the appropriate
code. The list of codes appears in a description-type field.

To view the code description, follow these steps:

1. Select the field that you wish to display from the Field list box.

2. Click Field Description. A new window appears. Your field and the corresponding codes should appear
in the list.
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24 Chapter 4: Creating Queries

Querying Selection-Type Fields in the Application

1120 Returns
Form type: Federal Workpaper

Form: General Information

Field name: Select the field name, condition and value for desired return type:

RETURN TYPE FIELD NAME CONDITION VALUE

1120 US Corporation = X

1120S S Corporation = X

1120F Foreign Corporation = X

1120-H Homeowners Association = X

1120-RIC Regulated Investment Company = X

1120-REIT Real Estate Investment Trust = X

1120-C Cooperative Associations = X

1065 Queries
Form type: Federal Organizer

Form: Schedule B

Field: Type of Partnership

The following table lists each condition and value for each partnership return type:

RETURN TYPE CONDITION VALUE

GENERAL PARTNERSHIP = G

LIMITED PARTNERSHIP = L

LIMITED LIABILITY COMPANY = C

LIMITED LIABILITY PARTNERSHIP = P
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Chapter 4: Creating Queries 25

Querying Selection-Type Fields in the Application

RETURN TYPE CONDITION VALUE

FOREIGN PARTNERSHIP = F

OTHER = O

1041 Queries
Form type: Federal Organizer

Form: General Information

Field: Select the appropriate field, condition and value for the desired return type.

FIELD NAME CONDITION VALUE

CH 11 Bankruptcy Estate = Y

CH 7 Bankruptcy Estate = X

Complex Trust 100 = X

Complex Trust 300 = X

Decedents Estate = X

Grantor Type Trust = X

Pooled Income Fund = X

Agency Entity Type = X

Simple Trust = X

Form 5227 = X
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26 Chapter 4: Creating Queries

Querying Selection-Type Fields in the Application

990 Queries
Form type: Federal Organizer

Form: 990 990EZ 990PF

Field: Select the appropriate field listed for the desired return type:

RETURN TYPE FIELD NAMES CONDITIONS VALUES

990EZ 990EZ = X

990T (TRUST) 990TTRUST = X

990 990 = X

990-PF (NONOPERATING
FOUNDATION)

PFNONOP = X

990-PF (OPERATING FOUNDATION
(IRC §4942(J)(3))

PFOPER1 = X

990-PF (OPERATING FOUNDATION
(IRC §4942 (J)(5))

PFOPER = X

990-T (CORPORATION) 990TCORP = X

990-N ENTER X IF
990N

= X
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CHAPTER 5: FORMSOURCE LIBRARIES
The following predefined queries are currently available in the FormSource Library:

1040
l Federal Returns that may qualify for early payment of CTC

l Federal Returns that should qualify for a third stimulus payment

l Federal Returns with Unemployment

l Arkansas Employment for the 2020 Tax Year

l Form 2210 Missing 2019 Overpayment Applied to Estimated Tax Amount

l Taxpayers Indicating Virtual Currency

l Form 8990 Limited Business Interest Expense Query

l Form 461 Limited Business Loss Query

1041
l Form 1041 Resident Tax Exempt Interest Allocation of Direct Expenses Query

l Form 8990 Limited Business Interest Expense Query

l Form 461 Limited Business Loss Query
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