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CHAPTER 1: CHANGES TO
DIF IMPORT/EXPORT FOR 2020
As we continue to modernize our compliance solutions and advance our technology strategy, we are excited to
announce the following updates.

Creation and editing of DIF/KAT files will no longer be available for tax year 2020 forward. The
following options will continue to be available and supported to allow for a more user-friendly experience.

l 1065 Partner Bridge
(https://tax.thomsonreuters.com/support/onesource/gosystem/?search=000102302) will be supported.

l CurrentDIF/KAT templates
(https://tax.thomsonreuters.com/support/onesource/gosystem/?search=000101533) supplied by
Thomson Reuters will be supported, as long as no changes to the template are required.

l Recently created Data Import templates
(https://tax.thomsonreuters.com/support/onesource/gosystem/?search=000102011) by Thomson
Reuters will be supported.

l Data Connection provides import/export methods that allow users to transfer data into and out of a
locator without manual data entry.

o Complimentary training will be made available for new adopters.

o Assistance with new file creation is available through our professional services team.

o Data Connection requires a separate license.

Importing existing DIF/KAT files can continue to be utilized if no changes are required to
the files.
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Import DIF Dialog Box

CHAPTER 2: COMPONENTS OF
ORGANIZER IMPORTING
The DIF import feature can populate virtually every field within Organizer. DIF import can be used to populate
Forms 4562, 8825, and areas such as contributions and distributions. Most commonly, DIF Import is used to
populate State Allocation and Apportionment information.

The three components of Organizer importing are:

l Import DIF dialog box

l DIF Import File

l DIF Template File.

IMPORT DIF DIALOG BOX
You can import from anywhere in the Organizer using the Import DIF dialog box. You can open the dialog box
by selecting File > Import > From DIF file.

Figure 2:1
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DIF Import File

The Import DIF dialog box shown above enables you to:

l Specify the DIF import file and DIF template file to be used in the import.

l Start the import process.

l Create or modify an import template file.

The functions of the two text boxes on the dialog are:

FUNCTION DESCRIPTION

DIF Import File location and filename of the DIF import file

DIF Template File location and filename of the Organizer import template (KAT file)

The functions of the command buttons on the dialog are:

FUNCTION DESCRIPTION

Import Execute the import specified by the Import DIF dialog box.

Browse Specify the disk drive, directory location, and filename of the DIF import file and DIF import
template file.

Done Close the Import DIF dialog box.

Edit
Template

Access the template dialog to create or modify the specified DIF template file.

DIF IMPORT FILE
The DIF Import File contains the data to be imported into the Organizer. Import source files for Organizer must
be in the Data Interchange Format. These files are created by spreadsheet programs such as Microsoft Excel.
Import source files are usually referred to as “DIF files.”
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DIF Import File

To make an import file, you use a spreadsheet such as the one below.

Figure 2:2
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DIF Template File

DIF TEMPLATE FILE
Import templates act as a “road-map” for data from the DIF import file to specific fields within Organizer. Import
template files have the extension KAT and cannot be opened or edited using Microsoft Excel. Import template
files are usually referred to as “KAT files.” Click Edit Template to access the DIF Coordinates dialog box.

Figure 2:3
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DIF Template File

Helpful Rules and Tips regarding Organizer Import Templates

l A single import template can be used to import data for multiple Organizer pages; there is no limit on the
number of data elements selected for import or the number of Organizer pages with import targets.

l You can modify import templates by adding or deleting references to Organizer data fields.

l The position of a selected data element in a DIF import file cannot change after the row and column
coordinates of the data element have been recorded in an import template.

l Multiple import templates can be used with a single DIF import file; each template specifies different data
file elements to be imported.

l To avoid confusion later, name source files and import template files in a way that defines their use.
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Creating the DIF Import File

CHAPTER 3: CREATING DIF AND KAT FILES
DIF/KAT creation and editing is available only in Tax Year 2019 and prior years. It is no longer
available starting with Tax Year 2020.

Creating a DIF and corresponding KAT file takes some preparation. The effort and planning pays off when the
same type of data will be imported repeatedly into the same Organizer or Organizers of different entities. The
repetitive data entry process is then quick and accurate.

DIF Template file (KAT) creation requires using Classic Organizer. This will not work
with the New Organizer.

l Creating the DIF Import File (page 7)

l Defining a Group DIF Template (page 7)

l Rows/Columns with Blank Cells (page 11)

CREATING THE DIF IMPORT FILE
You create the DIF import file by placing the data in an Excel spreadsheet in the desired format with fields
labeled appropriately.

1. In Excel, select File > Save As.

2. Browse to the location where the file will be saved.

3. In the File name field, enter the desired file name.

4. In the Save as type field, use the drop-down menu to selectDIF (Data Interchange Format)(*.dif)

5. Click Save.

DEFINING A GROUP DIF TEMPLATE
Defining a group DIF template involves extra steps. The first step in creating a group data import template is to
create the initial group member for the target group. To access a group member page in the Organizer for
Officers’ Compensation, a group member must exist.
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Defining a Group DIF Template

Create a new entry by selecting *Add New… Create the initial officer. Then access the Organizer page for the
individual officer to create the import template.

Figure 3:1

The temporary officer’s name created during template setup will disappear during the import of
officers’ compensation data after the import template is finished. So using a name like “officer” is
appropriate.

Defining a DIF Template

1. In Organizer, select File > Import > From DIF.

2. SelectBrowse beside the DIF Import File field. Browse to and open the saved DIF file.

3. Enter a name for the template file (including path) in the DIF Template File field.

Figure 3:2
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Defining a Group DIF Template

4. Select Edit Template to open the DIF file dialog box and DIF Coordinates (Template) dialog box.

Figure 3:3

5. If you are creating a new template (KAT file), the application confirms that a new template is being created.

6. Place the cursor in the appropriate Organizer field, and the DIF Coordinates dialog box should display its
name in the Target Field column. If the name does not appear, click a different field in the Organizer, and
click the previous field again.
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Defining a Group DIF Template

7. Click the matching cell from within the open DIF dialog box.

If you are importing a group, select the first data cell containing data to be imported so the
entire column is highlighted.

Figure 3:4

The DIF dialog box now shows the cells to be imported. If there is one cell matched to one
field (non-Group import) the Coordinates box will show Column, Row, and ending point:
for example B, 4, 4. If a group is being imported, the Coordinates box will show for
example C, 4, *meaning the group starts in cell C4 and continues as long as there is data
in the group.

8. Repeat steps 6 and 7 for every Organizer field that is to be defined.

9. Once all desired fields have been defined, selectComplete to return to the Import DIF dialog box.

10. In the DIF Import dialog box, click Import.

11. ClickDone to return to Organizer and view the imported data.
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Rows/Columns with Blank Cells

ROWS/COLUMNS WITH BLANK CELLS
Importing files that contain columns (for row processing mode) with blank cells, such as shown in the figure
below, may result in data not importing into the correct data set.

Figure 3:5

To resolve this problem, cells that are blank should be filled with spaces. In Excel, do the following:

1. Highlight columns G and I.

2. Click Edit > Replace.

3. Leave the Find what field blank.

4. Place the mouse in the Replace with field.

5. Press the space bar once.

6. ClickReplace All.

7. Save the file.
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Group Importing

CHAPTER 4: TYPES OF ORGANIZER
IMPORTING
Based on the type of data being imported, you can use any of four types of importing into Organizer:

l Group Importing (page 12)

l Non-Group Importing (page 16)

l Mixed Group and Non Group Importing (page 16)

l Multi-Level Group Importing (page 16)

GROUP IMPORTING
Group importing imports lists or groups of data. One type of group in the Organizer navigation tree shows *Add
new… This designates group data for which you can add new group members. The target screen for group
importing is called a “group screen” because it contains multiple sets of the same data. The example in the
following figure isOfficers’ Compensation in the 1120 Organizer.

Figure 4:1
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Group Importing

A second group screen is one in which target fields have multiple lines. The example in the following figure is on
the Schedule N Questions page of the 1120 Organizer.

Figure 4:2

Examples of group data in the federal section of the 1120 Organizer

l General Information > Corporation Owns 50% of Stock

l General Information > Owners of 50% or More of Stock

l Income and Deductions > Officers’ Compensation

l Income and Deductions > Passive, Rental and At-Risk

l Gains and Losses > 4797 Asset Sales

l Gains and Losses > Contracts Section 1256 contract

l Information Returns > Form 851 Part II Subsidiary corporations

l Foreign Information > Form 5471 Foreign corporations.

For importing into Organizer, there are two formats for group data: row and column formats. The two formats
differ by the arrangement of the group data in the import file.
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Group Importing

Group Data in Row Format
The sample worksheet below shows officers’ compensation data in row format:

Figure 4:3

This format results in the various group member data elements being in columns. In this example, all officer
names are in the first column, street addresses are in the second column, and so on.

Group Data in Column Format
The sample worksheet below shows the same officers’ compensation data in the column format. Column
formatting means that the group member data is arranged in columns with various group member data
elements.

Figure 4:4
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Group Importing

DIF only processes data contained with the Excel 2003 boundary: 65,536 rows by 256 columns. In a single-tier
group data, row processing will allow 65,536 items with 256 details to be imported, but column processing will
limit it to 256 items with 65,536 details. Multi-tiered group data transfer quickly reduces the number of items and
details that can be processed since sub-tier information requires additional rows and columns. Therefore, Excel
row and column limitation should be considered when setting up a DIF transfer file.

Group Control Field

When you create a KAT file for group data that includes a navigational item, the field for the navigational item
must be mapped first. With depreciation detail associated with an activity (i.e., rental activity), you must map the
activity name of the rental property first. It must be the first field in the KAT file (Cell A1). DIF directs you to do
this with the dialog below when you begin the template setup.

Figure 4:5

The import process will only work (group align all data) if the navigational field is in Cell A1. As long
as you properly map the navigational field first in Cell A1, the depreciation assets related to the
property as well as other imported data for this property will be group aligned. If you do not do this,
you will have trapped data. The data is imported into the locator files, but without the navigational
field being displayed in the navigation tree, you will never see it.
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Non-Group Importing

NON-GROUP IMPORTING
Non-group importing is importing into individual, non-repeating fields. The illustration below (from theGeneral
Information folder in the 1120 Organizer) contains only non-group data.

Figure 4:6

MIXED GROUP AND NON GROUP IMPORTING
Mixed group and non-group importing means having group and non-group data in the same import file.

Row and column formats for group data cannot be used in the same import template.

MULTI-LEVEL GROUP IMPORTING
l Multi-Level Group Screen (page 16)

l Multi-Level Group Screen Importing (page 18)

Multi-Level Group Screen
Multi-level group screen is an area in the Organizer where there is a group screen nesting inside another group
screen. The screens are identified by the presence of:

Multi-row fields inside a group screen (first screen below) or

Nested blue snowflake inside a group screen (second screen below).
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Multi-Level Group Importing

Two-Level Group Screen

Figure 4:7

Three-Level Group Screen

Figure 4:8
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Multi-Level Group Importing

Multi-Level Group Screen Importing
Multi-level group screen requires the DIF template to include mapping of the mandatory (interesting) fields of
each level. These fields are the factors that determine which group screens the sub-group detail should belong
to. A good example of multi-level group screen is the depreciation asset detail under passive activity (see the
following screen), where depreciation detail can be added for multiple passive activities.

Figure 4:9

In this example, DIF transfer process requires mapping of the mandatory (interesting) fields for the passive
activity (first level) (next screen),Activity Number and Activity Name, and Asset Description for
depreciation (second level) (previous screen).

Figure 4:10

For row processing, the DIF file may be set up as in the next screen.

Figure 4:11
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Multi-Level Group Importing

The DIF template can be set up using the point and click approach and for this example, the template will
include two additional coordinates as shown below.

Figure 4:12

Import file for the template in the previous figure has to be set up in a tiered format (next screen) for the asset
details to import into their associated passive activities (following screen).

Figure 4:13

Figure 4:14
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Multi-Level Group Importing

1040 has a four-level group screen to enter depletion depreciation detail for each business activity (Schedule
C). Before DIF import is possible, the mandatory fields under Business Information, Set Options, Property
Options, and the asset description have to be mapped properly.

Figure 4:15

For row processing, the DIF import file may be set up as shown below.

Figure 4:16
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Multi-Level Group Importing

Importing Organizer DIF Information with Existing DIF and KAT Files

1. Organize data in Microsoft Excel.

Figure 4:17

2. Save the file in DIF format.

3. Navigate to the appropriate area of Organizer. The page into which the data will import and populate need
not be open during the import. It is a good idea, however, to check to see if the data imports properly.

4. From the menu, select File > Import > From DIF file.

Figure 4:18
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Multi-Level Group Importing

5. Browse to and open the DIF Template File.

Figure 4:19

6. Click Import.
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Components of Organizer Exporting

CHAPTER 5: EXPORTING FROM
ORGANIZER

COMPONENTS OF ORGANIZER EXPORTING
The three components of Organizer exporting are:

l Export DIF dialog box

l DIF Import File

l DIF Template File.

Figure 5:1

EXPORTING DIF FILES FROM ORGANIZER
To export from Organizer, the steps of the DIF import process are reversed. A new DIF file is created
automatically during export. An existing KAT template must be used to direct data to the appropriate cells in the
spreadsheet.
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Exporting DIF Files from Organizer

Exporting from Organizer may be appropriate when the data was input manually and needs to be reviewed in a
different format, stored separate from the 1120 application, or imported into another return. Another
circumstance might be if data was imported from a DIF file and some data was manually changed. In this case,
you might want to update the original DIF import file with the modified data.

Exporting Data from the Organizer
1. To display the Export DIF dialog box, select File > Export > To DIF file.

2. Specify the targetDIF Export File.

3. Specify the DIF Template File.

Figure 5:2

4. Click Export.
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CHAPTER 6: FAQS
Can KAT Templates be re-used in different returns?

Yes. Once templates are created, they can be used for similar imports into the same return type.

Can I use multiple DIF Imports within one return?

Using two or more different imports will not accumulate or sum data in the same field(s) within Organizer. Each
import will overwrite the previous import. However, if each import populates a different area of Organizer (for
example, A&A property, A&A payroll), then multiple imports can be used.

Can I export using the same DIF import templates?

Yes. Create a blank file in Microsoft Excel and save it as DIF. From within the appropriate screen in Organizer
select File > Export > To DIF file and follow the same procedures as importing.

KAT Export templates can be created the same way that import templates are created to export
Organizer data.

Why does my template not import into certain Organizer fields when they are already
mapped?

You may have a corrupt mapping coordinates. Try deleting and adding back the coordinates. If this step does
not resolve the issue, the template is corrupted. A new template has to be created.

Can I use DIF import to append information?

No, DIF import only overwrites existing information. If you need to append data, export the information to a DIF
file, add the information to the export file, and then import back into the Organizer.

Does DIF import delete the excess information if the data i am importing is less than what is
in the Organizer?

No, DIF import does not delete the excess in the Organizer. You will need to delete the unwanted information
manually.
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26 Chapter 6: FAQs

In Organizer under Depletion Set Options, if an asset is deleted from the depletion
depreciation and amortization area of a depletion property, or, if a property is deleted from
a depletion set, can i export the remaining property sets and their assets from depletion set
options with DIF?

No. Once any asset has been deleted from a Depletion Property, or any Depletion Property has been deleted
from a Depletion Set, DIF cannot export the Depletion Set anymore. To continue to use DIF to import or export
the Depletions Set, users will need to delete all the Depletion Properties and their assets in Organizer using the
appropriate delete options on the Federal Deactivation tab underGeneral Information > Return and
Print Options.

Are there any pre-defined DIF and KAT Files that I may use?

Yes. Pre-defined DIF and KAT files are available for download on the Customer Center site. Once downloaded,
populate the files with information and perform the import. There is no KAT template to define!

Is there a way to delete information from a previous DIF import?

Yes, but you will need to delete the information individually and manually. There is no way to delete multiple
instances at one time.

Is there a way to delete amounts from a previous import?

Yes, edit your existing DIF file and replace the amounts with 0 (Blank does not work) and reimport the DIF file.
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